Degraded performance of GRID console due to AWS issues

Incident Report for DefenseStorm

Resolved

This incident has been resolved.
Posted Aug 31, 2021 - 16:25 PDT

Update

We are continuing to monitor for any further issues.
Posted Aug 31, 2021 - 16:23 PDT

Update

GRID functions are back to normal.
Posted Aug 31, 2021 - 15:06 PDT

Monitoring

AWS has improved but GRID may still experience degraded performance when viewing Dashboards and Reports.
Posted Aug 31, 2021 - 12:40 PDT

Update

We are continuing to investigate this issue.
Posted Aug 31, 2021 - 11:50 PDT

Investigating

US WEST region is having an issue which is impacting GRID console performance.
Posted Aug 31, 2021 - 11:44 PDT
This incident affected: GRID Console and AWS EC2.